Podium - Google Reviews are delayed pulling into Podium – Incident details

All systems operational

Google Reviews are delayed pulling into Podium

Resolved
Degraded performance
Started 6 days agoLasted 1 day

Affected

Public API

Operational from 4:07 PM to 11:23 PM, Degraded performance from 11:23 PM to 7:58 PM

Reviews

Degraded performance from 4:07 PM to 7:58 PM

Updates
  • Resolved
    Resolved

    This issue has now been resolved.

  • Update
    Update

    We're continuing to see a minor delay in pulling Google Reviews into Podium as well as issues around sending updates for users subscribed to webhooks for Google review notifications. Thank you for your patience.

  • Update
    Update

    Reviews are still delayed pulling into Podium. Users also subscribed to webhook notifications for reviews may not receive notifications

  • Monitoring
    Monitoring

    We've slowly been seeing reviews improve while still aware of some issues. We're continuing to monitor and work with our partners on a fix for this issue

  • Identified
    Identified

    Review performance is delayed, this includes reviews pulling in as well as responding to reviews. We believe this is only affecting Google reviews and are reaching out to understand more.

  • Investigating
    Investigating

    We've picked up on some strange behavior happening with Reviews, some reviews might not be pulling in right now. We're actively looking into this issue and will provide more details soon