Podium - Most outbound phone calls are failing – Incident details

All systems operational

Most outbound phone calls are failing

Resolved
Partial outage
Started about 14 hours agoLasted 22 minutes

Affected

Phones

Degraded performance from 8:28 PM to 8:50 PM

Updates
  • Update
    Update

    We have seen full resolution of the spike of errors after we implemented our fix. We appreciate your patience and apologies for any inconvenience this has caused.

    We are working on betterments to prevent similar incidents from occurring in the future.

  • Resolved
    Resolved

    We have identified the cause of the outbounds calls not going through.

    We have fixed the issue and outbound calling is now working.

  • Investigating
    Investigating

    We're seeing a huge spike in failed attempts when creating an outbound call. We've got all hands on deck and will provide more information as we discover more.