Podium - Large number of Bulk Messages are failing to send – Incident details

All systems operational

Large number of Bulk Messages are failing to send

Resolved
Major outage
Started 5 days agoLasted about 1 hour

Affected

Bulk Messaging

Degraded performance from 3:52 PM to 5:00 PM

Updates
  • Resolved
    UTC
    Resolved

    Bulk messages are now working normally. Thank you for your patience

  • Monitoring
    UTC
    Monitoring

    We're seeing improvement from our fix but will continue to monitor over the next hour or so to ensure stability has returned to normal

  • Identified
    UTC
    Identified

    We believe we've identified the root cause and are pushing a fix to address this. We'll monitor once this fix is live to ensure bulk messaging returns to normal functionality

  • Investigating
    UTC
    Investigating
    We're receiving a large number of reports of bulk messages failing to send. We are actively investigating