Podium - iOS - Location failing to load in location picker – Incident details
All systems operational
iOS - Location failing to load in location picker
Resolved
Degraded performance
Started 4 days agoSeptember 01, 2026Lasted 42 minutesSeptember 01, 20265:125:54 PMUTC
Affected
Mobile
Degraded performance from 5:12 PM to 5:54 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Investigating
UTC
Investigating
UTC
We are currently investigating an issue impacting multi location accounts. Users may see locations fail to load in the Inbox location picker.
We are also seeing long load times for new log-ins as another side effect of this issue.