Podium - Phone calls are failing – Incident details

All systems operational

Phone calls are failing

Resolved
Partial outage
Started 1 day agoLasted about 3 hours

Affected

Phones

Partial outage from 3:15 PM to 3:44 PM, Operational from 3:44 PM to 5:50 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring

    We're seeing inbound and outbound calls succeed again at a normal rate. We're actively monitoring and keeping a close eye on our threshold levels for the next 30 minutes to ensure we're in a good spot again

  • Update
    UTC
    Update

    We have a leading theory into what is causing inbound and outbound calls to fail for some users. We've got parallel workflows to validate and alleviate this issue and will provide further updates soon

  • Investigating
    UTC
    Investigating
    We're aware inbound and outbound calls are failing to connect. We've got all hands on deck to resolve this issue as quickly as possible and will provide an update soon.