Podium - Issues with call parks and calls not ringing – Incident details
Contact Support
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Contact Support
Get updates
Phones experiencing degraded performance
Report an Issue
Issues with call parks and calls not ringing
Resolved
Degraded performance
Started 8 days ago
September 17, 2026
Lasted less than a minute
September 17, 2026
8:52
8:52 PM
UTC
Affected
Phones
Operational from 8:52 PM to 8:52 PM
Updates
Resolved
September 17, 2026 at 8:52 PM
UTC
Resolved
September 17, 2026 at 8:52 PM
UTC
We are aware of the issue and we are currently investigating.
UTC
UTC
UTC