Podium - Some accounts seeing difficulties with requesting Payments – Incident details

All systems operational

Some accounts seeing difficulties with requesting Payments

Resolved
Degraded performance
Started over 1 year agoLasted 8 days

Affected

Payments

Degraded performance from 11:51 PM to 4:44 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved! Thanks for your patience.

  • Monitoring
    Monitoring

    We are currently implementing a more permanent fix for the accounts affected by this. More updates to come soon. Thanks for your patience!

  • Identified
    Update

    We thank you for your patience while we continue to work to resolve this issue.

    We're able to provide a workaround in the meantime. If you are running into this issue, navigate to Payments > Payment Settings and toggle off Affirm as a Default Payment Method. Then attempt to request the payment again.

    We will provide more updates as we receive them.

  • Identified
    Identified

    We have discovered a small subset of users running into difficulties with:

    • Sending Text-2-Pay links to customers
    • Completing Manual Entry payments

    The issue lies with our partners and we'll be working with them to ensure this issue is resolved as soon as possible. We'll provide updates here as we receive them.