Podium - Payment Method Settings Issue – Incident details

All systems operational

Payment Method Settings Issue

Resolved
Operational
Started over 1 year agoLasted 27 minutes

Affected

Payments

Operational from 7:52 PM to 8:18 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved! Thanks again for your patience.

  • Identified
    Identified

    We have identified an issue some users are having updating the Payment methods page within Payments Settings. We should have a fix for this soon. Thanks for your patience.