Podium - Saved cards not available for new payments – Incident details

All systems operational

Saved cards not available for new payments

Resolved
Degraded performance
Started 11 months agoLasted 23 minutes

Affected

Payments

Degraded performance from 4:21 PM to 4:43 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved!

  • Investigating
    Investigating

    We are currently investigating an incident where saved cards are not showing to use for payment methods. More updates to come soon.