Podium - Leads from Outlook aren't pulling in for some users – Incident details

All systems operational

Leads from Outlook aren't pulling in for some users

Resolved
Operational
Started 10 months agoLasted about 1 hour

Affected

LeadDrive

Operational from 6:38 PM to 7:33 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved, and no leads were lost.

  • Investigating
    Investigating

    We're running into issues with pulling in leads from Outlook emails. We've got our engineering team taking a look to get this issue resolved as soon as possible.