Podium - Inbox slow to load for some users – Incident details

All systems operational

Inbox slow to load for some users

Resolved
Degraded performance
Started 9 months agoLasted 22 minutes

Affected

Messaging

Degraded performance from 9:34 PM to 9:56 PM

Web Application

Degraded performance from 9:34 PM to 9:56 PM

Updates
  • Resolved
    Resolved

    The incident is now resolved!

  • Identified
    Identified

    We have identified the issue and we are working towards a fix.

  • Investigating
    Investigating

    We are currently investigating reports of users experiencing long loading times when attempting to access the inbox. We will continue to post updates as more information becomes available!