All systems operational

Resolved
Business Hours page errors

Started
February 12, 2024 at 8:15 PM
Status
Resolved after about 1 hour

Impact

Operational
Affected
Web Application
  • Resolved
    Resolved

    We have resolved the issue and the Business Page has returned to normal. A page refresh may be required

  • Identified
    Identified

    We have identified the issue and are working on a fix for this now.

  • Investigating
    Investigating

    We're seeing a number of strange behaviors revolving around the Business Hours page that are preventing certain changes from happening. We've got our engineering team taking a look into this now and will provide updates soon.