Podium - Some users unable to set their password – Incident details

All systems operational

Some users unable to set their password

Resolved
Operational
Started 4 months agoLasted 21 minutes

Affected

Podium Services

Degraded performance from 6:40 PM to 7:01 PM

Updates
  • Resolved
    Resolved

    We have resolved this incident. Thank you for your patience!

  • Investigating
    Investigating

    Some users, including first time users, are unable to set their passwords when accessing the platform. We've got our team taking a look and will provide an update shortly