All systems operational

Phones are down for the vast majority of customers

Resolved
Operational
Started 13 days ago Lasted about 2 hours

Affected

Phones
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We've noticed phones starting to go back online. We'll continue to monitor to ensure no new errors arise.

  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    We've identified an issue with some locations where Podium Phones are not connecting to receive or make calls. Our team is actively working towards resolution.