Scheduled for February 02, 2025 at 10:00 AM – 10:30 AM
Affects
Payments
Under maintenance from 10:00 AM to 10:30 AM
Completed
February 02, 2025 at 10:30 AMCompleted
February 02, 2025 at 10:30 AMMaintenance has completed successfully
In progress
February 02, 2025 at 10:00 AMIn progress
February 02, 2025 at 10:00 AMMaintenance is now in progress
Planned
February 02, 2025 at 10:00 AMPlanned
February 02, 2025 at 10:00 AMWe are planning to do some maintenance on our Payments product Feb 2nd, between 3:00 AM to 3:30 AM MST. During this time the Payments will be down and users will be unable to send or receive payments.