Scheduled for February 24, 2025 at 1:30 AM – 2:00 AM
Affects
Reviews
Under maintenance from 1:30 AM to 2:00 AM
Completed
February 24, 2025 at 2:00 AMCompleted
February 24, 2025 at 2:00 AMMaintenance has completed successfully
In progress
February 24, 2025 at 1:30 AMIn progress
February 24, 2025 at 1:30 AMMaintenance is now in progress
Planned
February 24, 2025 at 1:30 AMPlanned
February 24, 2025 at 1:30 AMWe are doing maintenance on our Reviews Product. During this time, customers will be unable to view or respond to reviews on the Reviews Page for about 30 minutes.
Review data will still be accessible in Reporting.