Podium - Some inbound and outbound Outlook emails failing – Incident details

LeadDrive experiencing degraded performance

Some inbound and outbound Outlook emails failing

Monitoring
Degraded performance
Started 9 days ago

Affected

LeadDrive

Degraded performance from 9:01 PM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    We are discussing the issue with Microsoft and are continuing to monitor it on our end.

  • Investigating
    Investigating
    We are aware of an issue right now where some inbound email leads from Outlook are not pulling into Podium. We are working on a fix.