Podium - The window that pops up when checking a new Lead is erroring out – Incident details
All systems operational
The window that pops up when checking a new Lead is erroring out
Resolved
Degraded performance
Started 6 days agoLasted about 1 hour
Affected
LeadDrive
Degraded performance from 8:10 PM to 9:11 PM
Updates
Resolved
Resolved
The incident has been downgraded to a high priority fix scheduled for tomorrow. In the meantime, if you are seeing the issue you can still access the Lead Details page by clicking on the Contact Profile and then on the Lead Updated section.
Identified
Identified
We have identified the cause for the error message and are working on a fix that should be live soon.
Investigating
Investigating
When clicking "More Details" on a lead, the window that pops up is showing an error message. Leads are still actively pulling in, but the details for them are not currently viewable. We're actively investigating and will provide an update soon.