Podium - Contact updates delayed – Incident details

All systems operational

Contact updates delayed

Resolved
Degraded performance
Started 3 days agoLasted about 21 hours

Affected

Contacts

Degraded performance from 6:31 PM to 3:08 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved, we appreciate your patience

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We are currently investigating this incident. Updates to contacts are delayed. No data is lost, but the changes are not being displayed.