Podium - Taxes applying to invoices with no tax – Incident details
Contact Support
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Contact Support
Get updates
All systems operational
Report an Issue
Taxes applying to invoices with no tax
Resolved
Degraded performance
Started about 10 hours ago
Lasted 5 minutes
Affected
Payments
Degraded performance from 11:03 PM to 11:08 PM
Updates
Resolved
June 17, 2026 at 11:08 PM
Resolved
June 17, 2026 at 11:08 PM
This issue has been resolved.
Identified
June 17, 2026 at 11:03 PM
Identified
June 17, 2026 at 11:03 PM
We're seeing taxes being applied to invoices that were not supposed to have taxes applied. We're working on a fix now.