All systems operational

Resolved
Google Business Messaging failing to launch

Started
April 06, 2023 at 8:51 PM
Status
Resolved after about 18 hours

Impact

Degraded performance
Affected
Messaging
  • Resolved

    This incident has been resolved.

  • Identified

    We are currently investigating an issue that is causing some users to experience an error when attempting to launch Google Business Messaging. We apologize for the inconvenience that this is causing, and we will continue to provide updates on this until we find a full resolution!