All systems operational

Resolved
Chat with Support unavailable

Started
May 02, 2023 at 4:00 PM
Status
Resolved after less than a minute

Impact

Partial outage
Affected
Podium Services
  • Resolved

    The Podium Live Chat with Support has intermittently been unavailable over the last two days due to platform issues. We have identified the issue and implemented a fix so that it is available again. We will continue to monitor Live Chat closely to ensure a high standard of service from us.