Get updates
Email
SMS
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Get updates
All systems operational
Report an Issue
Show current status
Resolved
Some users are unable to load the inbox
Started
May 08, 2023 at 4:31 PM
Status
Resolved after 4 minutes
Impact
Degraded performance
Affected
Messaging
Resolved
May 08, 2023 at 4:35 PM
Resolved
May 08, 2023 at 4:35 PM
This incident has been resolved.
Investigating
May 08, 2023 at 4:31 PM
Investigating
May 08, 2023 at 4:31 PM
We are currently investigating this incident.