All systems operational

Resolved
Some users unable to load Marketplace App Home Page

Started
May 09, 2023 at 4:25 PM
Status
Resolved after 33 minutes

Impact

Partial outage
Affected
Marketplace
  • Resolved

    This incident has been resolved.

  • Investigating

    We are currently investigating this incident.