All systems operational

Resolved
Slow deliverability issues

Started
May 17, 2023 at 4:07 PM
Status
Resolved after about 4 hours

Impact

Operational
Affected
Messaging
Campaigns
  • Resolved

    We have implemented some changes to our systems to get message sending for MMS type messages to a healthier place. We will continue to monitor and ensure that this fix has the intended results.

  • Investigating

    We are currently investigating an issue that is causing a delay in Messaging Delivery for messages that have an attachment such as an image, video, or a file.