Contacts experiencing degraded performance

Inbound Calls aren't triggering phones to ring

Resolved
Partial outage
Started 11 months ago Lasted about 2 hours

Affected

Phones
Updates
  • Resolved
    Resolved

    Our phone systems have fully recovered. We thank you for your patience during this incident.

  • Monitoring
    Monitoring

    Our phones appear to be returning to a regular state. However we will continue to monitor until our partner's system has fully recovered

  • Investigating
    Update

    We are working with our partners on a resolution for this incident. We will continue to provide updates on this incident as we receive them. We appreciate your patience.

  • Investigating
    Update

    Hardphones are currently unable to send or receive calls

    Softphones are able to send calls but will not ring for inbound calls. These calls are still going to voicemail and are not being dropped.

    We are still working to understand this issue to be able to provide an estimated time for when we will be back up.

  • Investigating
    Investigating

    We are currently investigating the cause of this issue and are working to get updates as quickly as possible