Podium - Contact details are not loading – Incident details

All systems operational

Contact details are not loading

Resolved
Degraded performance
Started 15 days agoLasted about 24 hours

Affected

Contacts

Degraded performance from 5:09 PM to 5:01 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    We're still working on implementing the fix for this issue. We appreciate your patience

  • Identified
    Identified

    We believe we've identified the root cause of this issue and are working on the best approach to resolution

  • Investigating
    Investigating
    We're receiving a large number of failures when attempting to load contact details. We're actively investigating the root cause